Scala IDE 2.0 增加重构支持

  • Alex Blewitt
  • 郭晓刚

2012 年 1 月 17 日

话题:JavaScalaIDE语言 & 开发

Scala IDE 赶在年底发布了 2.0 版Scala IDE 项目最初由Miles Sabin创立,后与Typesafe携手,造就了一个达到产品级质量的 Scala 开发环境。

Scala IDE 2.0 版是与 1.x 版并行的版本,它对底层的 Scala 编译器做了改动以完善 IDE 自身的代码提示和代码展开功能。2.0 版在正式发布之前,经历了 2011 年全年一系列 beta 测试,成功将 Scala 环境带到 Eclipse 3.6 平台,这个版本也可以在 Eclipse 3.7 上使用,但因为尚有一些小问题需要解决,暂时没有列为正式支持。

2.0 版的新特性有:代码补全(包括 implicits 展开)、鼠标悬停显示推断类型、智能重编译项目依赖项、集成 Maven 等现有工具。Scala IDE 将开发环境与 Eclipse 本身的 Java 调试器集成在一起,让 Java 开发者也能轻松地接受和运用 Scala 语言。

自从项目搬迁到 GitHub,已经有 22 次 fork,并且收到若干pull 请求。从中可以看出,搬迁到 GitHub 的确收到了鼓励社区贡献的效果。

InfoQ 采访了 Scala IDE 的项目领导人 Iulian Dragos,首先请教他 1.0 版和 2.0 版有哪些重要区别:

Iulian Dragos: 从用户的角度来说,可靠性和响应能力提高了。我们从头到脚翻新了编辑器和产生语法表示的编译器之间的交互,保证编辑器绝不会因为等待操作完成而陷入无响应状态。本次发布的亮点还有代码补全、代码内超链接和边打字边报告错误的功能。

我们还完成了新的项目构建器,支持构建存在依赖关系的多个项目(基于 Sbt 依赖跟踪引擎)。我敢说这个版本可以让你在任何规模的项目里面运用 Scala 语言。这个 IDE 本身就是用它自己来开发的,Scala 团队也用这个 IDE 来开发 Scala 编译器(项目规模超过 110 kLOC)。

InfoQ:Scala IDE 怎样跟自动化构建工具配合,比如 SBT 或者 Maven?

Iulian Dragos: Sbt 和 Maven 都有相应的插件可以导入 Eclipse 项目定义。你只需要在 Eclipse 工作空间里面导入需要的项目就可以了,没有别的额外步骤。

InfoQ:新版支持哪些重构和 Quick Fix 功能?

Iulian Dragos:2.0 版确实在重构支持方面进步了很多,这要感谢 Mirko Stocker 的贡献。现在支持的重构操作有 Extract/Inline Local、Extract Method、Rename、Organize Imports。还有一项 Quick Fix 功能,是从 classpath 查找类然后补全 import 条目。

InfoQ:是否允许 Scala 项目依赖于 Java 项目?反过来又行不行?可不可以在一个项目里混用 Java 和 Scala 代码?

Iulian Dragos:支持以上所有组合。

InfoQ:Scala IDE 未来的路线图怎么样?

Iulian Dragos:Typesafe 的 IDE 团队正在规划这个路线图,我们希望先和社区一起讨论。所以现在我不能确切地说将来会是什么样子,要看讨论的结果而定。

我们的项目跟任何开源项目一样,大家可以自主地插一脚进来,做出优秀的特性,然后我们将之纳入项目。其实现在已经接收到一些非常优秀的贡献,例如“Implicit 高亮”特性,我还知道 Matt Russell 正在开发语义高亮功能(即根据标识符的种类如 class/trait/val/var,分别赋予不同的显示样式)。“Implicit 高亮”功能已经进入了 2.1 版的每日构建版本。

在开发团队这边,下面有几个重点方向,一是改进 Scala 调试器(当前开发者只能用 Java 调试器来调试 Scala 代码),二是提供更清爽的 API 给其他插件的开发者在 Scala 代码结构上实现各种操作(例如实现测试框架的运行器),还有就是代码搜索(如用于查找引用)。我们还计划为 Scala interpreter 设计更好的用户界面,因为有很多用户提出了这样的要求。

InfoQ:为什么 Scala IDE 分成两个版本?

Iulian Dragos: Scala IDE 依赖 Scala 编译器去完成所有的语义操作。举例来说,你输入的时候,错误的地方会被红色下划线标出来。为了让显示的结果和项目编译的结果一致,我们要在编辑器背后使用同样的编译器。所以,如果你的项目采用 Scala 2.8,那就必须用对应 2.8 的插件。因为并不存在一个编译器开关让 2.9 编译器以 2.8 兼容模式工作,所以,我们只好在插件里分别放入 2.8 或者 2.9 的编译器,分成两个版本。

InfoQ:你们有没有一套贡献者协议书,让其他人也能向项目提交补丁?

Iulian Dragos:有的。我们用的是 Scala 许可,贡献者协议也和 Scala 项目相同。我们尽量让大家更容易参与进来,我非常乐于看到越来越多人贡献力量。在 2.0 版发布之前,我们花了很多时间去整理开发文档,大家可以参考开发文档里面的“能做些什么”页面,我们无任欢迎!

读者现在就可以去下载 Scala IDE。因为 IDE 分为两个版本(各自对应一个版本的 Scala),所以有两个 update site。你可以可以任选一个来安装,但是不可以同时安装在一个 Eclipse 实例里面。

您对这次的新版 Scala IDE 有何看法?

查看英文原文:Scala IDE 2.0 Adds Refactoring Support

JavaScalaIDE语言 & 开发