Ember 社区对于取消 IE8 的支持表现出压倒性的支持

阅读数:1469 2015 年 5 月 5 日

话题:JavaScript语言 & 开发

Ember.js 的用户对于取消支持 IE8 的意见投票中表现出了压倒性的支持。

Ember 的共同开发者 Tom Dale 和 Yehuda Katz 在本月早些时候,通过一个征求意见项目向社区提出了这一问题,即是否还要继续对 IE8 的支持。

Dale 和 Katz 表示,在他们向整个团队提出取消 IE8 的支持这一意见时,发现没有人表示要继续支持它,并且继续支持 IE8 的成本明显超过了所得的利益。

在 Dale 对这一决定所发表的相关帖子中,他表示他们所收集的用户意见表明:“大多数 Ember 的用户”对于在 Ember 2.0 中放弃支持 IE8 这一点都表示“完全可以接受”。

这篇帖子中对于放弃 IE8 所带来的好处进行了详细的说明,其中一点在于这可以使 Ember 团队“获得一次机会,让 jQuery 不再成为严格的依赖。”但 Dale 同时也打消了人们的顾虑,他表示“他们不会删除那些使用了 jQuery 的 Ember API。”

除了能够移除 jQuery 这个依赖之外,这份意见征求文档中还概述了取消 IE8 支持能够带来的多个潜在的好处,包括移除 get() 方法、实现更多的 ES6 特性、支持更多的事件类型,以及 CSS 方面的改进。

Ember 的这份意见征求文档特地引用了ES6 特性,它将事实完全展现在读者面前:

如果继续支持 IE8,我们在 Ember 内核中采用新的 ES6 特性的能力将受到限制……

如果我们继续支持 IE8,那么我们就无法将完全过渡到让 JavaScript 类作为 Ember 体验中的第一等的功能。正如我们之前对模块所做的一样,我们希望将更多的核心代码转换为未来将出现的 JavaScript 特性,而由于 IE8 中缺少了 defineProperty 这一方法,将严重地影响这一计划的完成。

Ember 1.x 系列的最后一个版本将会是 1.13。Dale 表示,对于用户来说,如果在运行 Ember 1.13 时没有产生任何过期方法的提示,那么“从 Ember 1.13 升级到最新版本的 Ember 2.x 也会变得相对容易。”

从 1.13 开始,Ember 核心团队将定期地发布浏览器兼容性问题的 bug 修复与补丁,但他们也推荐用户尽快迁移到 2.x 系列版本上,除非用户必须支持 IE8。

GitHub上,对于取消支持 IE8 意见的反馈非常明确。HealthSparq 的 UI 开发者 Evan Rowe 这样说道

虽然在 HealthSparq 中,我们依然不得不继续支持 IE8,但根据使用情况统计来看,前端工程团队一直在争取早日取消对 8(有可能包括 9,它的使用率在我们网站上也非常低)的支持。看完这份意见征求文档之后,我们更明确的了解,在 Ember 2.0 中继续支持 IE8 的成本要高于支持它所带来的利益。

我支持取消对 IE8 的支持,这是为了这个框架好(希望对整个生态系统也是件好事),并且这一决定有可能会使我们内部的浏览器支持矩阵向前发展。

在所有的反馈意见中,最激烈的要数 Ade Bateman 了,他是微软 Internet Explorer 团队的一位项目经理。他是这样说的

我在 IE 团队工作,我们正在尽一切可能让用户不再使用 IE8(以及 9 和 10)。正如我们所说的一样,对它的支持到 2016 年就结束了,但这并不意味着之后就没人再使用它(就像我们所看到的 Windows XP 的情况一样)……

我建议 Ember不必再受 IE8 的拖累,而应当支持 IE11 和“斯巴达项目”。

Ember 讨论论坛上,对于取消 IE8 支持的决定也是一片支持的声音。

虽然反馈中也表示“对于取消 IE9 支持的意见也得到了广泛的支持”,但 Dale 表示,经过与许多大公司的 Ember 用户进行对话,并且看过了许多人私下里通过邮件表示的意见之后,他认为取消支持 IE9 所带来的利益“并不足以让他们放弃 IE9”。

Ember.js 的授权方式是基于 MIT licence 许可的。InfoQ 的读者们可以通过GitHub 上的项目为 Ember.js 贡献自己的力量。

查看英文原文:Ember Community Votes Overwhelmingly to Drop IE8