苹果对于所有新的 Watch 应用提交都要求 WatchOS 2

  • Sergio De Simone
  • 薛梦迪

2016 年 5 月 16 日

话题:移动AppleiOS语言 & 开发

苹果宣称新的在 2016 年 6 月 1 日后提交的 watchOS app 都必须是使用 watchOS 2 SDK 或更新版本开发的原生 app。而且,苹果更新了它在 App Store 中的审核标准。

苹果在 WWDC 2015 中发布了 watchOS 2 来给更强大又快速发展的 app提供机会。在 watchOS 2 的主要功能中有对所谓的原生 app 的支持,也就是不需要 iPhone 就能运行的 app,并且提供了对 Apple Watch 硬件更好的支持,例如 Wi-Fi、数码表冠、扩音器等。

但是,开发者们已经慢慢地更新他们的 app 至 watchOS 2。运动日志的共同创始人和 CEO Jason Jacobs解释道,转化至一个原生 app 需要许多工作,其中包括了整个重写和理解如何控制手表和 iPhone 间的交流。Mac Stories 的 Frederico Viticci指出了奖励机制的缺乏,由此解释了开发人员对 watchOS 2 的“沉默”反应和为什么他们忽略了它。

在过去,苹果通常会依照一个两阶段的方法来确保开发者适应了它最新的技术,一开始要求所有的新 app 遵守一个最低限度的 SDK 需求,然后再扩展这些规则使已存在 app 的更新也满足要求。尽管这对于那些定期维护的 app 很成功,而在不再更新的旧 app 身上则未能解决这一问题,Viticci 评论道。

在一个有关的记录中,苹果还为 App Store 提供了新的评审标准,他们在最后一次更新的六个月后发布了这个标准。更值得注意的是,新的标准引入了一个要求,它会影响所有使用后台位置服务应 app——即在后台跟踪你的位置信息的 app——通过要求他们指定一个获取用户许可的理由。

此外,所有的键盘扩展现在需要真正地支持输入字符,而我们已经知道了一些 app 安装了键盘来提供跨应用的 UI,以便处理例如剪贴板管理等的功能。

查看英文原文Apple Requires WatchOS 2 for All New Watch App Submissions


感谢张龙对本文的审校。

给 InfoQ 中文站投稿或者参与内容翻译工作,请邮件至editors@cn.infoq.com。也欢迎大家通过新浪微博(@InfoQ@丁晓昀),微信(微信号:InfoQChina)关注我们。

移动AppleiOS语言 & 开发