Visual Studio 2017 发布关键补丁

  • Jeff Martin
  • Rays

2017 年 8 月 22 日

话题:.NET语言 & 开发

任何使用 Visual Studio 2017 做 F# 开发的用户,以及对各种语言使用 Git 工具集的用户,都应确保他们已升级到最新的VS2017 15.3.1 版本。该更新版本紧随着上周发布的重大版本 15.3 而给出的,其中包括 F# 开发人员所必须的补丁,以及解决 Git 允许远程代码执行漏洞的重大安全补丁。

大多数 F# 开发人员会受到 15.3 版本中一个软件缺陷的影响。该缺陷会导致回车键、空格键和方向键间歇性失灵,进而会额外地导致一个问题,即如果一个要打开的已有解决方案中已经具有一些打开的文档,那么上述编辑按键在这些已被打开的文档中会失灵。

如果开发人员在 VS2017 中使用 Git,那么也应将 VS2017 升级到 15.3.1 版本。这是因为该版本修复了一个严重的安全缺陷,该缺陷会允许任意代码的执行。仅是克隆(Clone)被破坏的代码库,可以导致这一漏洞被利用。因此对于 VS2017 用户而言,尽快做升级是非常重要的。(应该指出的是,这并非是 VS2017 所独有的缺陷,开发人员应该确保所有基于 Git 的工具都打了补丁。)幸运的是,据 Microsoft 的 Edward Thomsom 介绍,该漏洞并未影响到 VS2015 及更早期的版本。

VS2017 可以通过访问惯常位置升级,也可以在 VS2017 内做自身升级。

查看英文原文: Crucial Patch for Visual Studio 2017 Released

.NET语言 & 开发