Dart 1.6 发布,支持延迟加载

  • 臧秀涛

2014 年 8 月 29 日

话题:语言 & 开发架构

Dart是 Google 于 2011 年发布的一门开源的编程语言,旨在帮助开发者克服 JavaScript 的缺点。今年 8 月 27 日,Dart 1.6 发布了。该版本最大的亮点是Dart VMdart2js增加了对延迟加载的实验性支持。有了这一特性,有些体积比较大的库可以推迟到真正需要时再加载,有助于减少加载时间并改进用户体验。Dart 网站有一篇文章描述了如何使用延迟加载特性。

除此之外,该版本在改进安全性方面也做了很多工作。比如 dart:core 中的 Uri 类有多处调整,以改进一致性和安全性。这可能会破坏现有的应用,不合规的 URI 将不再解析。具体可以参见这里的说明。dart:io 中的 HttpServer 默认发送的 HTTP 首部也考虑了安全因素

编辑器也有很多改进,比如编辑器的内存占用显著减少,现在调试器中可以更好地显示集合类型以及改进了调试器的激活(Activation)视图和实例变量的显示等。

更多细节,请查看发布说明。感兴趣的读者也可以下载该版本并加以尝试。


感谢张逸对本文的审校。

给 InfoQ 中文站投稿或者参与内容翻译工作,请邮件至editors@cn.infoq.com。也欢迎大家通过新浪微博(@InfoQ)或者腾讯微博(@InfoQ)关注我们,并与我们的编辑和其他读者朋友交流。

语言 & 开发架构