Flash Player 11.1.102 安全更新概述

  • Adobe

2011 年 11 月 14 日

话题:语言 & 开发架构

注意:本文仅适用于开发人员。遇到 Adobe Flash Player 安装问题的客户应该首先在Flash Player 支持中心中排出问题。

Adobe Flash Player 11.1.102 安全更新解决了安全公告APSB11-28中描述的问题。最新的 Flash Player 更新可从Flash Player 下载中心获得。Adobe 建议尽快安装所有安全更新。

在发布过去的多个 Adobe Flash Player 版本的过程中,我们向 Adobe Developer Connection 发表了多篇文章,探讨了由于所需的安全模型更改而可能对现有内容发生的潜在更改。我们提前通告这些更改的目的是尽早为您提供尽可能多的信息,以便您可以避免您的内容中断。

对于 Flash Player 11.1.102,无需预先通告,因为安全模型更改应该不会影响您的任何现有内容。这是一种准则。当然,Flash Player 在其历史中发布了一些次要版本,但大部分开发人员都不知道它们,因为它们对开发人员的工作没有影响。

最小化安全更改的影响

向后兼容性已成为 Flash Player 成功的一大特征,这得益于我们对不断出现的安全问题的迅速响应。我们尝试尽可能小心地平衡这两个目标。在每个安全版本中,我们都尽力避免对现有内容带来任何影响。

当响应安全问题不可避免要更改内容时,我们的首要目标是尝试设计修复程序,对设计方式的管理无需重新编译 SWF 文件。我们寻求可通过更改 HTML、跨域策略文件或服务器配置来生效的解决方案。只有当无法这么做时,我们才做出实现需要更改 SWF 文件的解决方案的艰难决策。

我们会非常严肃地对待兼容性问题,所以如果您在安装 Flash Player 11.1.102 之后遇到 SWF 文件行为的任何变化,请通过在我们的公共Flash Player 错误和问题管理系统中记录问题来联系 Adobe。这是让 Flash Player 团队分析问题的最佳和最快的方式。有关更多信息,请阅读Flash Player 错误和问题管理系统简介

准备安装未来的安全版本

确保您的内容不受安全版本影响的最佳方式是保持消息灵通。有关您响应安全更改提前通告所需执行的操作的最新信息,请定期查阅Flash Player 开发人员中心Adobe AIR 开发人员中心。有关您需要进行的更改的权威信息将在这里发布。

您也可以关注 Adobe 产品安全事故响应团队(PSIRT)的博客。PSIRT 博客将包含即将发布的 Flash Player 版本中可能影响您的内容的安全更改公告,还会引用针对我们的产品的任何安全公告和官方公告。

您可以在安全公告和官方公告页面上找到所有 Adobe 产品的补丁信息。这里您可以注册获取我们的通知服务,它将在我们的补丁公告发布时通知您。

查看原文:Overview of the Flash Player 11.1.102 Security Update

语言 & 开发架构