支持 VB 的.NET Core 2.0 预览版发布了

阅读数:1036 2017 年 5 月 22 日

话题:.NETC#语言 & 开发

微软发布了.NET Core 2.0 的第一个预览版,它带来了对.NET Standard 2.0 的支持,大家对此已经翘首以盼多时。其中的一个重大变更是它为.NET Core 开发人员增加了大量的 API,比.NET Core 1 超出了 20,000 多个。通过遵循.NET Standard,开发人员可以更容易地跨多种.NET 兼容平台使用自己的代码了,比如传统的.NET 框架、.NET Core,以及 Xamarin。

在 Linux 上开展工作的开发人员很乐于看到.NET Core 2 将 Linux 作为一个单独的平台来看待,而不是需要开发人员把一个或多个特定的 Linux 发行版作为目标。然而,你仍然需要针对.NET Core 2 预览版下载一个发行版特定(DEB、RPM 等等)的安装程序,这一方面没有变化。Mac 开发人员应该更容易上手使用.NET Core 2 了,因为它不再需要安装 OpenSSL,已经用本地 Apple 加密类库予以代替。

现在支持 Visual Basic 了

许多 Visual Basic 开发人员对.NET Core 1 缺少 VB 支持表示不满。.NET Core 2 已经没有这个问题了,因为它添加了对 VB 的支持。VB 开发人员可以针对 .NET Core 和 .NET Standard 编写控制台应用程序了。

如何使用.NET Core 2.0 预览版

Visual Studio 2017 默认将继续使用.NET Core 1.X,目前使用.NET Core 2 的最简单方式是安装它的 15.3 预览版和 .NET Core 2 Preview SDK。你可以在 GitHub 上查看完整的版本说明

查看英文原文.NET Core 2.0 Preview Released, Includes Visual Basic Support