Dart 1.5 支持移动 Web 开发

  • 马德奎

2014 年 7 月 2 日

话题:Android语言 & 开发

近日,Dart 官网宣布了 1.5 版本,该版本的发布周期非常短,只有四个星期。它包含一个可以在 Android 设备上运行的开发版 Dartium——带 Dart 运行时环境的 Chrome。

Dart 编辑器也进行了更新,它现在支持调试用 Dart 编写的移动 Web 应用程序。在一台与开发机器有着相同开发流程的设备上,开发人员可以设置断点以及调试异常。为了配置移动开发环境,开发人员需要做的准备工作包括:

  • 一部 Android 手机或一台 Android 平板电脑
  • 一根将 Android 设备连接到开发机器的 USB 连接线
  • 在开发机器和 Android 设备上安装 Chrome

要了解具体操作步骤,可以查看入门文档

此外,Dart Polymer 包增加了两组新的 Polymer 元素。core_elemenets使 Dart 开发人员可以访问所有的 Polymer 基础设施组件。paper_elements包含的 Polymer 元素遵循 Google I/O 2014 上宣布的material design模式。

要了解更多关于该最新版本的信息,可以查看发布说明

用户可以从Dart 下载页面下载 Dart 1.5。而如果你正在运行 Dart 编辑器,那么你可以通过检查“关于 Dart 编辑器”进行更新。

要获取帮助、报告问题、或是为项目做贡献,请登录Dart 支持页面

Android语言 & 开发