PhoneGap 3.5.0 不再支持 iOS 5 并且将不支持 WP 7

  • Abel Avram
  • 梅雪松

2014 年 6 月 15 日

话题:HTML5iOS语言 & 开发

Cordova/PhoneGap 3.5.0 不再支持 iOS 5,3.6.0+ 将不再支持 WP 7,以后的更新将通过 npm 管理。

PhoneGap 3.5.0构建于相同版本的Cordova,已经停止支持 iOS 5。根据这个特性提升需求的说明,主要原因是 Cordovas 只支持当前和上一个 iOS 版本。这意味着不再支持 iPad 1,因为它无法升级到 iOS 6。

另一个变化是放弃支持 iOS 6 arm64,因为苹果要求 iOS 6 的应用只能是 32 位版本。同时,Xcode 5.0.1 和之后的版本为 iOS 6 生成 32 位,iOS 7 生成 32 位和 64 位文件。

这是 PhoneGap 支持 Windows Phone 7 的最后一个版本。

PhoneGap 推荐的安装方法不再是下载文件,而是通过 npm 安装。所有平台都已经有了顶层的 package.json 文件,并已经提交到 npm。以后框架的升级将通过 npm 交付而不是 git。

发布说明提供了这个新版本所有变更的详细信息。

查看英文原文:PhoneGap 3.5.0 No Longer Supports iOS 5 and Won’t Support WP 7

HTML5iOS语言 & 开发