Amazon ElastiCache Redis 5.0 兼容版

阅读数:46 2019 年 10 月 16 日 11:13

Amazon ElastiCache Redis 5.0 兼容版

今年早些时候,我们推出了 Amazon ElastiCache Redis 4.0 兼容版。在当时发布的博文中, Randall 说明了 ElastiCache for Redis 集群如何扩展到 TB 级内存以及每秒数百万次读取和写入! 最近,我们对 Amazon ElastiCache for Redis 进行了另外一些改进,其中包括:

只读副本扩展 – 支持向 Redis 集群添加或从中移除只读副本节点,同时节省高达 40% 的集群创建时间。

PCI DSS 合规性 – 经过认证符合支付卡行业数据安全标准 (PCI DSS)。这可让您使用 ElastiCache for Redis(引擎版本 4.0.10 及更高)构建低延迟、高吞吐量的应用程序,来处理敏感的支付卡数据。

获得 FedRAMP 的授权并在 AWS GovCloud(美国)区域提供 – 美国政府客户及其合作伙伴可以使用 ElastiCache for Redis 在 AWS GovCloud(美国)区域处理和存储他们的 FedRAMP 系统及数据,以便执行影响广泛的任务关键型工作负载,并在美国的其他 AWS 区域处理影响力中等的工作负载。有关更多信息,请参阅 ElastiCache for Redis 合规性文档。

就地升级 – 支持就地将 Redis 集群升级至更新的引擎版本,同时保持可用性,故障转移期仅有几秒。

新的实例类型 – 支持使用 M5 和 R5 实例,性能得到了极大提升。

5.0 兼容版
今天,我很开心地宣布推出 Amazon ElastiCache for Redis 的 Redis 5.0 兼容版。此版本的 Redis 支持在有序集合上使用新的数据类型以及新命令( ZPOPMIN ZPOPMAX ),而且可以更好地整理内存。有关更多信息,请参阅 What’s New in Redis 5?

您可以一如既往地通过 ElastiCache 控制台 CLI API CloudFormation 模板开始使用。我将使用控制台,因此需要进行以下设置:

Amazon ElastiCache Redis 5.0 兼容版

我的集群已启动,将在几分钟内运行:

Amazon ElastiCache Redis 5.0 兼容版

我还可以对兼容 4.0 的现有集群使用我在前面提到的就地升级功能。我选择集群,单击修改,然后会发现兼容 5.0 的引擎已选中。我确认其他设置,然后单击修改继续操作:

Amazon ElastiCache Redis 5.0 兼容版

流的实际应用
新的流数据类型功能十分强大! 每个流都有名称,只需通过将其作为 XADD 命令的一部分进行引用即可创建。假设我有一个长期运行的流程,该流程生成的文件需要进行扫描和验证。为了进行测试,我可以如下所示向流名称文件添加一堆文件:

Bash

复制代码
$ find /usr -name 'a*' -exec redis-cli -h r5cluster.seutl3.ng.0001.use1.cache.amazonaws.com \
XADD Files \* f {} \;

我可以使用命令 XREAD BLOCK 1000 STREAMS Files 0 从流开头处开始检索值:

Amazon ElastiCache Redis 5.0 兼容版

我还可以读取指定 ID 之后的值:

Amazon ElastiCache Redis 5.0 兼容版

当然,多数情况下,我会通过代码(而非使用命令行)执行读取和写入。上面只是简单举例说明了 Redis 5 流的强大功能,我相信大家可以做得更好!

现已推出
您可以立即在所有 AWS 商业区域升级兼容 4.0 的现有集群,也可以创建兼容 5.0 的新集群。

作者介绍:
Jeff Barr

复制代码
AWS 首席布道师; 2004 年开始发布博客,此后便笔耕不辍。
** 本文转载自 AWS 技术博客。**

原文链接:
https://amazonaws-china.com/cn/blogs/china/new-redis-5-0-compatibility-for-amazon-elasticache/

欲了解 AWS 的更多信息,请访问【AWS 技术专区】

评论

发布