Flash Player 10.3.181 安全更新概述

阅读数:315 2011 年 6 月 1 日

话题:Java.NETRuby语言 & 开发

注意:本文仅适用于开发人员。遇到 Adobe Flash Player 安装问题的客户应该从Flash Player 支持中心开始排除问题。

Adobe Flash Player 10.3.181 安全更新解决了安全公告APSB11-12中描述的问题。最新的 Flash Player 更新可从Flash Player 下载中心获得。Adobe 建议尽快安装所有安全更新。

在过去几个 Adobe Flash Player 版本中,我们向 Adobe Developer Connection 发表了文章来探讨由于所需的安全模型更改,可能发生的对现有内容的潜在更改。我们预先通告这些更改的目的是尽早为您提供尽可能多的信息,以便您可以避免对内容的破坏。

对于 Flash Player 10.3.181,没有需要预先通告的信息,因为安全模型更改不会影响您的任何现有的内容。这是一种惯例。诚然,Flash Player 在其历史上发布过次要版本,但大部分开发人员不知道它们,因为对他们的工作没有影响。

最小化安全更改的影响

向后兼容性是 Flash Player 成功的特征,因为我们要快速响应不断出现的安全问题。我们尝试尽可能小心地权衡这两个目标。在每个安全版本中,我们都尽力避免对现有内容的任何影响。

当响应安全问题不可避免要更改内容时,我们的首要目标是尝试以无需重新编译 SWF 文件即可管理的方式来设计修复程序。我们寻找可通过更改 HTML、跨域策略文件或服务器配置来实现的解决方案。只有在无法这么做时,我们才艰难地决定实现需要更改 SWF 文件的解决方案。

我们高度重视兼容性错误,所以如果您在安装 Flash Player 10.3.181 之后,遇到了 SWF 文件行为上的任何更改,请联系 Adobe,在我们公共的Flash Player 错误和问题管理系统中填写错误。这是让 Flash Player 团队分析该问题的最佳和最快的方式。关于更多信息,请参阅Flash Player 错误和问题管理系统简介

为未来的安全版本做准备

确保您的内容不受安全版本影响的最佳方式是随时关注最新信息。关于您需要如何响应安全更改预先通告的最新信息,请定期访问Flash Player 开发中心Adobe AIR 开发中心。关于您需要执行的更改的权威信息将在这里发布。

您也可以关注 Adobe 产品安全事故响应团队的博客。PSIRT 博客将包含即将发布的 Flash Player 版本中可能影响您的内容的安全更改公告链接,也将引用关于我们的产品的任何安全公告和建议。

您可以在安全公告和建议页面上找到所有 Adobe 产品的补丁信息。在这里您可以注册我们的通知服务,该服务将在我们的补丁公告发布时向您通知它们。