Apache Dubbo 被曝出“高危”远程代码执行漏洞

发布于:2020 年 6 月 24 日 10:25

Apache Dubbo被曝出“高危”远程代码执行漏洞

Apache Dubbo被曝出“高危”远程代码执行漏洞

6 月 23 日,360 网络安全响应中心(360CERT)发布《CVE-2020-1948:Apache Dubbo 远程代码执行漏洞通告》(以下简称《通告》)。《通告》称,Apache Dubbo 存在远程代码执行漏洞,受影响的版本有 Dubbo 2.5.x、Dubbo 2.6.0 - 2.6.7 和 Dubbo 2.7.0 - 2.7.6。

根据 360CERT 的评定,该漏洞等级为高危,影响面广泛。

Apache Dubbo 官方表示,Apache Dubbo Provider 存在反序列化漏洞。攻击者可以通过 RPC 请求发送无法识别的服务名称或方法名称以及一些恶意参数有效载荷,当恶意参数被反序列化时,可以造成远程代码执行。

据悉, Apache Dubbo 是一款高性能、轻量级的开源 Java RPC 框架,它提供了三大核心能力:面向接口的远程方法调用,智能容错和负载均衡,以及服务自动注册和发现。

通用修复建议:

建议广大用户及时升级到 2.7.7 或更高版本,下载地址: https://github.com/apache/dubbo/releases/tag/dubbo-2.7.7

阅读数:2 发布于:2020 年 6 月 24 日 10:25

评论

发布
暂无评论